Okay
  Public Ticket #1169127
not PHP 7 compatible
Open

Comments

  • Alex started the conversation

    hi, I was gonna update my website php version and Siteground tool scanned plugins and themes for possible errors and found 2 on your theme. Could you fix them so i can update the php version. See the errors below:

    1- The following plugins/themes are not compatible with PHP 7.0.

    consultsolutions

    FILE: /home/myfolder/public_html/mysite.com/wp-content/themes/consultsolutions/woocommerce/single-product/related.php
    -----------------------------------------------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------------------------------
     58 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    -----------------------------------------------------------------------------------------------------------------------

    FILE: /home/myfolder/public_html/mysite.com/wp-content/themes/consultsolutions/woocommerce/single-product/up-sells.php
    ------------------------------------------------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    ------------------------------------------------------------------------------------------------------------------------
     51 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    ------------------------------------------------------------------------------------------------------------------------

    FILE: /home/myfolder/public_html/mysite.com/wp-content/themes/consultsolutions/woocommerce/cart/cross-sells.php
    -----------------------------------------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------------------------
     54 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    -----------------------------------------------------------------------------------------------------------------

    2- WPOPAL Framework For Themes See Errors 

    FILE: /home/myfolder/public_html/mysite.com/wp-content/plugins/wpopal-themer/import/import.php
    --------------------------------------------------------------------------------------------------------------
    FOUND 2 ERRORS AFFECTING 2 LINES
    --------------------------------------------------------------------------------------------------------------
     264 | ERROR | Function split() is deprecated since PHP 5.3 and removed since PHP 7.0; use preg_split instead
     269 | ERROR | Function split() is deprecated since PHP 5.3 and removed since PHP 7.0; use preg_split instead
    --------------------------------------------------------------------------------------------------------------

    FILE: /home/myfolder/public_html/mysite.com/wp-content/plugins/wpopal-themer/import/class.wordpress-importer.php
    ------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ------------------------------------------------------------------------------------------------------------------
     137 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ------------------------------------------------------------------------------------------------------------------

  •  242
    Opal replied

    Hi there,

    Sorry for late response.

    About your issue, please download latest version theme on themeforest.net and update for your site.

    VIew guide at: https://wpopal.ticksy.com/article/10510

    Then, let me know if you need to help.

    Regards.


    Opal Support Team

    We are located in GMT +7 time zone and we answer all questions within 12-48 hours in weekdays. In some rare cases the waiting time can be to 48 hours. Support tickets sent during weekends or public holidays will be processed next Monday or the next business day. 

    If you like our theme, Please vote it 5 stars. We are really really appreciate your vote :
    To vote go to http://themeforest.net/downloads then follow that link : http://screencast.com/t/ylPjXebiCIOE
    Thanks and have a nice day

    Website: http://wpopal.com/

  •   Alex replied privately
  •  242
    Opal replied

    Hi,

    Please send FTP account and Admin web account for me, I will check and try to help you.

    Opal Support Team

    We are located in GMT +7 time zone and we answer all questions within 12-48 hours in weekdays. In some rare cases the waiting time can be to 48 hours. Support tickets sent during weekends or public holidays will be processed next Monday or the next business day. 

    If you like our theme, Please vote it 5 stars. We are really really appreciate your vote :
    To vote go to http://themeforest.net/downloads then follow that link : http://screencast.com/t/ylPjXebiCIOE
    Thanks and have a nice day

    Website: http://wpopal.com/

  •   Alex replied privately
  •  242
    Opal replied

    Hi,

    I think the problem from your hosting, please contact with hosting to update version PHP

    Opal Support Team

    We are located in GMT +7 time zone and we answer all questions within 12-48 hours in weekdays. In some rare cases the waiting time can be to 48 hours. Support tickets sent during weekends or public holidays will be processed next Monday or the next business day. 

    If you like our theme, Please vote it 5 stars. We are really really appreciate your vote :
    To vote go to http://themeforest.net/downloads then follow that link : http://screencast.com/t/ylPjXebiCIOE
    Thanks and have a nice day

    Website: http://wpopal.com/

  • Alex replied

    what? seriously?? that is NOT the issue, i can myself update the php version, but i haven't done it because the SG tool diagnosed a couple possible errors associated with your theme files (as i clearly posted them in here) if i udpade it!

  •  242
    Opal replied

    Hi again,

    I checked our theme on our hosting and it's ok.

    Please try to update version PHP and recheck.

    Opal Support Team

    We are located in GMT +7 time zone and we answer all questions within 12-48 hours in weekdays. In some rare cases the waiting time can be to 48 hours. Support tickets sent during weekends or public holidays will be processed next Monday or the next business day. 

    If you like our theme, Please vote it 5 stars. We are really really appreciate your vote :
    To vote go to http://themeforest.net/downloads then follow that link : http://screencast.com/t/ylPjXebiCIOE
    Thanks and have a nice day

    Website: http://wpopal.com/