Okay
  Public Ticket #2837837
EKOMMART "Create an Account" link goes to Wordpress registration instead of site regristration ONLY ON HOME PAGE
Closed

Comments

  • Anthony Baystate started the conversation

    EKOMMART THEME

    I had recently found out I had this problem, I looked online for an answer. I found one but I figured out that the function works on every other page but the home page. This is the function I had found 

    if ( ! function_exists( 'ekommart_form_login' ) ) {    function ekommart_form_login() { ?>         <div class="login-form-head">            <span class="login-form-title"><?php esc_attr_e( 'Sign in', 'ekommart' ) ?></span>            <span class="pull-right">                <a class="register-link" href="<?php echo get_permalink( get_option('woocommerce_myaccount_page_id') ); ?>"                   title="<?php esc_attr_e( 'Register', 'ekommart' ); ?>"><?php esc_attr_e( 'Create an Account', 'ekommart' ); ?></a>            </span>        </div>        <form class="ekommart-login-form-ajax" data-toggle="validator">            <p>                <label><?php esc_attr_e( 'Username or email', 'ekommart' ); ?> <span class="required">*</span></label>                <input name="username" type="text" required placeholder="<?php esc_attr_e( 'Username', 'ekommart' ) ?>">            </p>            <p>                <label><?php esc_attr_e( 'Password', 'ekommart' ); ?> <span class="required">*</span></label>                <input name="password" type="password" required placeholder="<?php esc_attr_e( 'Password', 'ekommart' ) ?>">            </p>            <button type="submit" data-button-action class="btn btn-primary btn-block w-100 mt-1"><?php esc_html_e( 'Login', 'ekommart' ) ?></button>            <input type="hidden" name="action" value="ekommart_login">            <?php wp_nonce_field( 'ajax-ekommart-login-nonce', 'security-login' ); ?>        </form>        <div class="login-form-bottom">            <a href="<?php echo wp_lostpassword_url( get_permalink() ); ?>" class="lostpass-link" title="<?php esc_attr_e( 'Lost your password?', 'ekommart' ); ?>"><?php esc_attr_e( 'Lost your password?', 'ekommart' ); ?></a>        </div>        <?php    } }

    Can anyone help me, Thank You.

    Attached files:  Screenshot 2021-07-29 185517.jpg

  •  1,946
    Opal replied

    Dear mate,

    Please refer to our guide : https://byduoc.gitbook.io/change-link-my-an-account/

    Or send me info login admin site. We will check for you.

    Thanks.


    WpOpal Support Team

    We are located in GMT +7 time zone and we answer all questions within 12-48 hours in weekdays. In some rare cases the waiting time can be to 48 hours. Support tickets sent during weekends or public holidays will be processed next Monday or the next business day. 

    If you like our theme, Please vote it 5 stars. We are really really appreciate your vote :
    To vote go to http://themeforest.net/downloads then follow that link : Here

    Thanks and have a nice day

    Website: http://wpopal.com/ | Follow to Get Our Promotion Themes

  • Anthony Baystate replied

    Thank you, I had some problems but I fixed them by eventually switching the theme back to the original (I was in the child theme all this time I fixed my problem by switching to the original)

  •  1,946
    Opal replied

    Dear mate,

    Sorry for the late reply on weekends.

    If you still have any problems, please let me know. I will be here to assist you.

    Best Regards,



    WpOpal Support Team

    We are located in GMT +7 time zone and we answer all questions within 12-48 hours in weekdays. In some rare cases the waiting time can be to 48 hours. Support tickets sent during weekends or public holidays will be processed next Monday or the next business day. 

    If you like our theme, Please vote it 5 stars. We are really really appreciate your vote :
    To vote go to http://themeforest.net/downloads then follow that link : Here

    Thanks and have a nice day

    Website: http://wpopal.com/ | Follow to Get Our Promotion Themes